[Date Prev][Date Next] [Chronological] [Thread] [Top]

[CTSim-Users] Install Problem with CTSim 4.5.3


  • Subject: [CTSim-Users] Install Problem with CTSim 4.5.3
  • From: Graham.Jenkins at its.monash.edu.au (Graham Jenkins)
  • Date: Mon, 06 Aug 2007 11:52:16 +1000

I'm experiencing some difficulty compiling the above on a Scientific
Linux 5 machine on an x86_64 platform with wxwidgets (X11) 2.8.4.

./configure .. successfully finds wx-config .. but doesn't actually
write anything about the ws library and include files in any of its
resultant Makefiles.

So it gets as far as: "Making all in src"
Then dies with all sorts of errors like: "ctsim.cpp:32:23: error:
wx/wxprec.h: No such file or directory"

And even if one sets (before doing ./configure):
LDFLAGS='-I/opt/sw/wxwidgets-2.8.4/lib/wx/include/x11univ-ansi-release-2.8
-I/opt/sw/wxwidgets-2.8.4/include/wx-2.8'

And: LIBS='-L/opt/sw/wxwidgets-2.8.4/lib -pthread -L/usr/lib64
-lwx_x11univ_aui-2.8 -lwx_x11univ_xrc-2.8 .. " ..

.. that still doesn't seem to resolve the problem.


So .. anybody got some suggestions .. please?
-- 
Graham Jenkins
Senior Software Specialist, E-Research

Email: Graham.Jenkins at its.monash.edu.au
Tel:   +613 9905-5942
Mob:   +614 4850-2491



Please send sugestions and comments to kevin@ctsim.org.